Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Inventory Bugs

  1. #1

    Inventory Bugs

    Not sure where to post bugs.

    Im having an issue where my inventory gets messed up. Items picked up will overwrite items I have in my hot bar. Some times Items will be picked up but not show up in my inventory or will show up but then something else I had will disappear.

    If I log out and back in SOME of the items will show up again. Moving these items to boxes and logging out and back in will get other items to show up. But it makes farming really hard.

    Also if I die and go get my body and stuff then it makes the issue even more messed up with items no placed in the hot bar being gone some times for ever.

  2. #2
    Thanks for the report LordTulkus - could you send us an output log to contactus@cardlifegame.com please? Also, which server was this on?

    To get the log, it's usually in C:\Games\CardLife\Logs

  3. #3
    Sent.

    Its in single player. I have not played on a public server. Not my thing.
    Last edited by LordTulkus; 05-10-2018 at 06:12 PM.

  4. #4
    I can confirm this as well. I've had it occur on dedicated server and multiplayer session as well. I'll post my logs the next time it occurs but it's seemingly random. I'm trying to watch for a pattern to see if there is a root cause but here's what I can say so far...

    1) Sometimes when I drag an item to a slot on my hot bar, it's there but when I hit the corresponding button nothing happens. For example, if I have a tool on that hot button, nothing happens when I hit the respective number. Or if I am trying to place dirt for example, nothing happens either, doesn't even appear in my hands.
    2) When #1 happens, I can drag the item back in my inventory, sometimes I'll see the icon like it's there but it actually isn't or it may even duplicate the items.
    3) Sometimes with #2 the icon will be there but the items isn't
    4) I've seen the issue correct itself but not sure what fixes it
    5) After I restart the game it usually corrects the problem but sometimes the items will disappear.

  5. #5
    I have seen the duplicate issue too. Did it with Boxes. made one then got two then got 4 then got 8

  6. #6
    Hi all,

    thanks for the info! I am trying to look into these issues and trying to reproduce them. So far all I did not manage to get a 100% working set of steps that would reproduce these issues and would explain what is going on. So if you come across these issues, please let us know so we can understand more clearly what has happened.

    For example:

    Expected behaviour:
    Crafted a tool (pickaxe) and wanted to equip it in the hotbar so I can mine

    Experienced behaviour:
    The pickaxe icon correctly appeared in the hotbar, but had no durability bar and when selected the respective slot on the hotbar, the tool did not appear in my hand and I was unable to mine.

    Work around (if any):
    Re-joining the server fixed the issue and I was able to use the tool


    The above is just an example of how to write a report to us, not an actual 100% description of the problem. If you have any new info, please feel free to report them here or find me on Discord in the boooogs room. Thanks!

  7. #7
    Expected behavior:
    Looking to repair a tool (axe) by putting it in the forge. Then putting in my copper (already melted). Did this to look if there was a recipe. (there wasn't)

    experienced behaviour
    the too dissapeared, and the durability bar stayed. The copper overlayed the tool. No way of getting the tool out after getting the copper out.

    work around
    I emptied my inventorie and logged out. I guess when i log back in it will be OK. (note: it wasn't)

    for me the problem of dissapearing items occurs when the game doesn't close properly (i think the files get corrupted)

    also i cannot change the keys, i use an azerty-keyboard so wasd isn't all that easy. tried changing the keys whilst starting the game up.
    the new keys appear but when the game start the new keys are not applied. also the arrows don't work.

    that is all i've encountered so far after playing for a couple of hours
    keep up the good work

  8. #8

    Exclamation

    Light wolf pelt -> coarse hide = nothing

    Expected behaviour:
    Crafted a coarse hide from light wolf pelt after throwing it into the crafting slot and pressing selecting "All" to find the recipe

    Experienced behaviour:
    Crafting the recipe used up the resource (light wolf pelt) but did not give me any coarse hide

    Work around (if any):
    None, but have not attempted reset as it would kick my wife off the game.
    Last edited by TacticBlack; 05-21-2018 at 04:28 AM. Reason: Wanted to add signature. Forgot that gets turned on elsewhere.

  9. #9
    System Specs are in signature below now in the event that helps. Thanks Devs!
    System Specs:

    OS: Windows 10 Home
    Processor: AMD FX-6300 Six-Core Processor -- 3.50 GHz
    RAM: 24 GB
    System Type: 64-bit OS and Processor

  10. #10
    Quote Originally Posted by TacticBlack View Post
    Light wolf pelt -> coarse hide = nothing

    Expected behaviour:
    Crafted a coarse hide from light wolf pelt after throwing it into the crafting slot and pressing selecting "All" to find the recipe

    Experienced behaviour:
    Crafting the recipe used up the resource (light wolf pelt) but did not give me any coarse hide

    Work around (if any):
    None, but have not attempted reset as it would kick my wife off the game.
    Addendum: When logging into the game I found the coarse hides in my inventory. However, once I attempted to make leather out of them, it did the animations like they were being made, but they too never appeared.
    System Specs:

    OS: Windows 10 Home
    Processor: AMD FX-6300 Six-Core Processor -- 3.50 GHz
    RAM: 24 GB
    System Type: 64-bit OS and Processor

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •