Results 1 to 7 of 7

Thread: Forums Login

  1. #1

    Question Forums Login

    Hi, all! Cardlife seems to be doing really well, but there is a problem with logging into the Forums. Every time I open the forums page, it makes me log in. When I put in my Cardlife username and password, it doesn't let me in. I have to go back to the home page, and then to the forums again. Do you know anything about this?

  2. #2
    Hey Cake_Commander,

    That seems strange - I'll pass this information onto our server programmer to see if he knows anything about it. Thanks for letting us know.

    Cheers
    Rich

  3. #3
    I suspect it's related to the issue I raised in http://cardlifegame.com/forums/showt...th-the-website - I found if you hit the main page, you'll get some errors from the PHP code. If you then refresh, it appears to sort itself out. This also affects the forum login.

  4. #4
    Yes more than likely.

  5. #5
    We have just pushed a fix for this. Hopefully any login should now take you to the main login page on cardlifegame.com

    Let me know if you have any issues with it or you notice something weird.

  6. #6
    Sorry to say that I'm still seeing whatever is behind this issue. I suspect it's down to an issue refreshing the session when the browser already has valid cookies. The outcome is that when you first hit the site, you hit some PHP errors and I'm assuming this is screwing up the server-side session. Refreshing the main landing page once you've got the error seems to fix it. Trying to browse the forums without refreshing the landing page makes it seem that you're not logged in. These seem to be the symptoms that cake_commander is seeing.

    I hit the site at about 20:55, so there may be some stuff in the php error log at about that time. The error output given to the web browser is:

    Code:
    Warning: Missing argument 1 for plgAuthenticationCardLifeAuthentication::onBeforeRender() in /var/www/html/plugins/authentication/cardlifeauthentication/cardlifeauthentication.php on line 25
    
    Warning: Cannot modify header information - headers already sent by (output started at /var/www/html/plugins/authentication/cardlifeauthentication/cardlifeauthentication.php:25) in /var/www/html/cl-forums.php on line 125
    
    Warning: Cannot modify header information - headers already sent by (output started at /var/www/html/plugins/authentication/cardlifeauthentication/cardlifeauthentication.php:25) in /var/www/html/cl-forums.php on line 126
    
    Warning: Cannot modify header information - headers already sent by (output started at /var/www/html/plugins/authentication/cardlifeauthentication/cardlifeauthentication.php:25) in /var/www/html/cl-forums.php on line 127
    
    Warning: Cannot modify header information - headers already sent by (output started at /var/www/html/plugins/authentication/cardlifeauthentication/cardlifeauthentication.php:25) in /var/www/html/cl-forums.php on line 128
    
    Warning: Cannot modify header information - headers already sent by (output started at /var/www/html/plugins/authentication/cardlifeauthentication/cardlifeauthentication.php:25) in /var/www/html/cl-forums.php on line 129
    Last edited by Zhang; 07-10-2017 at 09:02 PM.

  7. #7
    That error still exists and we need to still fix it - Ill pass on your info to our server programmer though.

    The fix that we pushed live was to do with an erroneous forum login page that actually didn't do anything even though it looked like a legitimate page. It should now redirect to the main login page on the main website.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •