Page 5 of 7 FirstFirst ... 34567 LastLast
Results 41 to 50 of 61

Thread: Setting up a "dedicated" server

  1. #41
    Quote Originally Posted by Rich View Post
    Zhang at the moment is pioneering that front as one of our super fans.
    Thanks - I thought I was just making more work for you guys!

  2. #42
    Quote Originally Posted by Decatater View Post
    ran the file (made a shortcut to set the target with -batchmode at the end, and have tried running it through the command prompt with -batchmode, both resulting in it crashing, so I went back to running the file without batchmode.) It starts and it's just the skybox, and after a short while some of the assets will appear briefly, as if it's loading them. The problem lies where I cannot see it in the server list, but I can play the server from the host option.
    Running the server with -batchmode means the server goes into the background, so you won't see a window or anything similar. Check your task list, and it should be running there. I'm not quite sure how CardLife handles it if you try to start two servers for the same game ID and that may well cause problems. Running without -batchmode will get you the skybox, and that's expected.

    My suggestion would be to ensure no servers are started, remove any log files, and then start the server. Don't start the game client (yet). Give it a few minutes and look at the log files again. That should give some indication as to what's happening (maybe).

  3. #43
    Quote Originally Posted by Britor View Post
    is there a way i can send you or anyone my Output log? i really need some help
    You can put it up on pastebin (or similar) and put the link in this thread.

  4. #44
    Quote Originally Posted by zancka View Post
    UniqueIds not loaded from the database, uniqueIds must be loaded before the server can connect
    Make sure the server is not running. Try the CardLife game in multiplayer mode to ensure that works.

  5. #45
    "42809 DEBUG - [19:32:20.621] OnJoinedRoom Room: '02b1434c-1b10-41e4-9d81-0a308adff335' hidden,open 1/101 players. - Logging.RemoteLogger(0)
    GameServer.ServerUtilities.ServerThreadedLogger.St artQueue > GameServer.ServerUtilities.ServerThreadedLogger.Fl ushLogger > UnityEngine.Debug.Log > UnityEngine.Logger.Log > UnityEngine.DebugLogHandler.LogFormat > UnityEngine.DebugLogHandler.Internal_Log > UnityEngine.Application.CallLogCallback > Logging.RemoteLogger.LogMessageReceived"

    It says that when I look at the log, and I'm wondering if that "hidden,open 1/101 players." has anything to do with the fact that I can't see my server in the server list

  6. #46

    Exclamation My Server isn't shown on the Server list

    Hey Guys,
    I tried to host a dedicated Server too, but my server isn't shown on the server list!!
    Pls help :c

  7. #47
    my outpit log file says at the end...UniqueIds not loaded from the database, uniqueIds must be loaded before the server can connect. Any ideas

  8. #48
    i have setup a server every thing looks like its running good and loaded fine, but we cannot see the server in the list, any help would be awesome.

    4/15/2018 5:21:10 PM
    [17:21:05.420] game server registered to lobby

    4/15/2018 5:21:35 PM
    OnConnectedToPhoton

    4/15/2018 5:21:35 PM
    OnConnectedToMaster

    everything looks good but i still have no server in the list , server name is Cardboard Against Humanity

    4/15/2018 6:15:53 PM
    [18:15:51.827] -!!!!!!-> OnUpdateStateFailed

    4/15/2018 6:15:58 PM
    [18:15:56.891] -!!!!!!-> The remote server returned an error: (500) Internal Server Error.: Exception on Notification: server does not own game

    this is where im at any help guys?
    Last edited by ShotGunExit; 04-15-2018 at 07:13 PM. Reason: Working But Not Now

  9. #49
    I'm another one that seem to have followed the steps, but without the server showing up in the list.

    https://pastebin.com/rihkXXUk

  10. #50
    Quote Originally Posted by Butthole View Post
    my outpit log file says at the end...UniqueIds not loaded from the database, uniqueIds must be loaded before the server can connect. Any ideas
    I think it's still setting up, and you just have to wait a bit.
    At least my log looked something like that until it updated.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •